

<!DOCTYPE html>
<!--[if lt IE 7]><html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en"><![endif]-->
<!--[if IE 7]><html class="no-js lt-ie9 lt-ie8" lang="en"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9" lang="en"><![endif]-->
<!--[if IE 9]><html class="no-js ie9" lang="en"><![endif]-->
<!--[if (gt IE 9)|!(IE)]><!-->
<html class="no-js" lang="en">
<!--<![endif]-->
<head><meta name="description" content="Terry Pheto rubbed shoulders with Hollywood A-listers at this year&#39;s Essence Black Women in Hollywood Awards." /><title>
	SA’s Terry Pheto meets Viola Davis and snaps an awesome pic! | Channel24
</title><meta charset="utf-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" /><meta name="viewport" content="width=device-width" /><meta name="bitly-verification" content="81a26829a6e4" /><link rel="SHORTCUT ICON" href="../../../images/sport24_favicon.ico" /><meta property="article:published_time" content="2017-02-25 08:30:58 AM"/><meta property="article:modified_time" content="2017-02-25 08:30:58 AM"/><meta property="article:expiration_time" content="2017-02-27 09:12:26 AM"/><meta property="twitter:card" content="summary"/><meta property="twitter:url" content="http://www.channel24.co.za/The-Juice/News/sas-terry-pheto-meets-viola-davis-and-snaps-an-awesome-pic-20170225"/><meta property="twitter:title" content="SA’s Terry Pheto meets Viola Davis and snaps an awesome pic!"/><meta property="twitter:site" content="Channel24"/><meta property="twitter:description" content="Terry Pheto rubbed shoulders with Hollywood A-listers at this year&#39;s Essence Black Women in Hollywood Awards."/><meta property="twitter:image" content="http://cdn.24.co.za/files/Cms/General/d/4897/1133a55f0c144c12b8f1c761672d5e08.jpg"/><meta name="cXenseParse:pageclass" content="article"/><meta name="cXenseParse:recs:articleid" content="72038933146537218107303804779997525769"/><meta name="cXenseParse:recs:publishtime" content="2017-02-25T08:30:58.000Z"/><meta name="cXenseParse:recs:category" content="Channel/The-Juice/News"/><meta name="cXenseParse:tss-section" content="The-Juice"/><meta name="cXenseParse:recs:tss-section" content="The-Juice"/><meta name="cXenseParse:tss-category" content="News"/><meta name="cXenseParse:tss-breadcrumb" content="The-Juice/News"/><meta property="og:site_name" content="Channel"/><meta property="fb:app_id" content="166885289993532"/><meta property="fb:page_id" content="233091425159"/><meta property="og:title" content="SA’s Terry Pheto meets Viola Davis and snaps an awesome pic!"/><meta property="og:type" content="article"/><meta property="og:url" content="http://www.channel24.co.za/The-Juice/News/sas-terry-pheto-meets-viola-davis-and-snaps-an-awesome-pic-20170225"/><meta property="og:image" content="http://cdn.24.co.za/files/Cms/General/d/1755/99f7736be77e46a38cdce37efb0b6ec0.jpg"/><meta property="og:image:width" content="300"/><meta property="og:image:height" content="300"/><meta property="og:description" content="Terry Pheto rubbed shoulders with Hollywood A-listers at this year&#39;s Essence Black Women in Hollywood Awards."/><link rel="canonical" href="http://www.channel24.co.za/The-Juice/News/sas-terry-pheto-meets-viola-davis-and-snaps-an-awesome-pic-20170225"/><link type="text/css" rel="stylesheet" href="/The-Juice/styles/site.css?v=20170213" /><link type="text/css" rel="stylesheet" href="http://scripts.24.co.za/libs/fancybox/jquery.fancybox.css?v=17" /><script type="text/javascript" language="javascript" src="/The-Juice/Scripts/common-top.js?v=20170213" ></script><script type="text/javascript" language="javascript" src="/The-Juice/scripts/menu.js?v=20170213" ></script><script type="text/javascript" language="javascript" src="http://scripts.24.co.za/libs/fancybox/fancybox-1.3.4.min.js?v=16" ></script><script type="text/javascript" language="javascript" src="/The-Juice/scripts/jquery.jcarousel.load.js?v=20170213" ></script>
        <script type="text/javascript">
            var $j = jQuery.noConflict();
            var isHomePage = false;
            document.domain = "channel24.co.za";
            var _sf_startpt = (new Date()).getTime();
            var tinaUrl = 'http://auth.channel24.co.za';
            var logoutUrl = 'http://auth.channel24.co.za/DeAuthenticate.aspx?surl=http://www.channel24.co.za//The-Juice/News/sas-terry-pheto-meets-viola-davis-and-snaps-an-awesome-pic-20170225';
        </script>
    <script sync type="text/javascript" src="http://scripts.24.co.za/libs/24com/portal/1.0/common.min.js?v=16"></script><script type="text/javascript">var _gaq = _gaq || [];_gaq.push(['_setDomainName', 'www.channel24.co.za']);_gaq.push(['_setAccount', 'UA-45055449-1']);_gaq.push(['_trackPageview']);
                                    (function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
                                    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
                                    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
                                    })();</script>
	
    <meta name="articleid" content="363231a0-35cb-43f4-bab6-04574cdd7709"/>

<link type="text/css" rel="stylesheet" href="http://scripts.24.co.za/libs/nuggad/1.0/nuggad.opt.css?v=1" />
<script type="text/javascript" language="javascript" src="http://scripts.24.co.za/libs/nuggad/1.0/nuggad.common.js?v=1"></script>
<!-- // START 1010172972	channel24.co.za --> <script type="text/javascript">var n_pbt = Array();document.write('<scr'+'ipt type=\"text/javascript\" src=\"//southernx.nuggad.net/rc?nuggn=95508456&nuggsid=1010172972"><\/scr'+'ipt>');</script> <!-- // END  -->
<script type="text/javascript" src="http://survey.nuggad.net/c/layer-html/s:southernx:channel24.co.za/script.js"></script>
<script type="text/javascript">
        document.write('<scr' + 'ipt type="text/javascript" src="http' + (location.protocol === 'https:' ? 's://s' : '://') + 'cdn.cxense.com/cx.js"></scr' + 'ipt>');
</script>
<script>
                var cX = cX || {}; 
                cX.callQueue = cX.callQueue || [];
                cX.callQueue.push(['setSiteId', '1137295542889888932']);
                cX.callQueue.push(['sendPageViewEvent']);
                
    (function(e){                  
                                try{
                                                e.za24_exk= e.za24_exk || new Array();
                                                e.za24_exkt= e.za24_exkt || new Array();                           
                                                e.za24_exkt.push('CxSegments');
                                                e.za24_exk.push(cX.getUserSegmentIds({ persistedQueryId: '6108e7e5ee629759870206096a1d3949eca98b12' }))         
                                }
                                catch(e){                                              
                                }
                })(window);        
</script>

<meta property="fb:pages" content="233091425159" />
<!-- Hotjar Tracking Code for http://www.channel24.co.za/ -->
<script>
    (function(h,o,t,j,a,r){
        h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
        h._hjSettings={hjid:308127,hjsv:5};
        a=o.getElementsByTagName('head')[0];
        r=o.createElement('script');r.async=1;
        r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
        a.appendChild(r);
    })(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');
</script>
<link href="http://scripts.24.co.za/libs/24com/comments/3.0.1/styles/comments.min.css" type="text/css" rel="stylesheet"></link>
<!-- Start of DClick Header -->
<!-- Site: /8900/24.com/Web/Channel24/, Zone: /TheJuice/News, MapsTo: "News" -->

<script src='//www.googletagservices.com/tag/js/gpt.js' type='text/javascript' ></script>
<script src="http://scripts.24.co.za/libs/24com/Ads/3.0/24AdScript.min.js" language="JavaScript" type="text/javascript"></script>
<script language="JavaScript" type="text/javascript">//<![CDATA[
za24_AdSite = '/8900/24.com/Web/Channel24/'; 
za24_AdZone = '/TheJuice/News';
za24_IsAsync  = false;
za24_InterstitialEnabled=false;
za24_KeywordType[1]='artid'; za24_Keywords[1]='363231a0-35cb-43f4-bab6-04574cdd7709'; 
za24_KeywordType[2]='people'; za24_Keywords[2]='alfre woodardviola davisterry pheto'; 
za24_KeywordType[3]='places'; za24_Keywords[3]='south africahollywood'; 
za24_KeywordType[4]='topics'; za24_Keywords[4]='local celebritiescelebrities'; 
za24_KeywordType[5]='accreditation'; za24_Keywords[5]='thejuice'; 

za24_AdSize[1]='1000x1000'; za24_AdPositionNo[1]='1'; 
za24_AdSize[2]='728x90'; za24_AdPositionNo[2]='1'; 
za24_AdSize[3]='300x600'; za24_AdPositionNo[3]='1'; 
za24_AdSize[4]='300x250'; za24_AdPositionNo[4]='1'; 
za24_InitAds();
//--></script>
<!-- End of DClick Header -->
</head>
<body id="superrugby">
    <form name="form1" method="post" id="form1">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="vA+c/8qXMH23i8w8RSxNaThJkBSUYLb+CzIVLaItwcQ7G4HQZ4dlCV+w9GYMoyVjZ/2XUFs2302MWlcbGCt7xmzULBQ=" />

<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="C3ED9682" />
<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="mH0cWZYcBt/k//idVcbD+CxHaLEqIpxfV5spKXAt3+XOUP1RfFd7+q2e0khcr2XClFZ6w8xTCS32BlQMH0MezgF3A0hJfwE/JTT4FLtDIQQ9kY828Trzw4HdHcd5iU/pUkY5qw==" />
        <script type="text/javascript">if(typeof za24_Keywords != "undefined") za24_Keywords ="alfrewoodard,violadavis,terrypheto,southafrica,hollywood,localcelebrities,celebrities";</script>
        <div style="display: none;">
            <script type="text/javascript">
jQuery('head').append("<link href='http://scripts.24.co.za/libs/24com/ads/2.0/Style/TransAd.css?v=17' type='text/css' rel='stylesheet' ></link>")
</script>
<script type="text/javascript" src="http://scripts.24.co.za/libs/24com/ads/2.0/script/TransAd.min.js?v=16"></script>
<div id="ad-10x10-1" class="24ad10x10"><script type="text/javascript">if(typeof za24_DisplayAd != "undefined") za24_DisplayAd("10x10","1");</script></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=10x10&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=10x10&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" border="0" alt="" /></a></noscript>
        </div>

        <div class='personalisationContainer'><div class='personalisationNav'><div class='topNavWrapper'><div class='bold headerLinks left'><span>
<a href='http://www.news24.com' target='_self' data-track='outbound,topbar,news24.com'>NEWS24</a>&nbsp;&nbsp;|&nbsp;&nbsp;
<a href='http://www.olx.co.za' target='_self' data-track='outbound,topbar,olx.co.za'>OLX</a>&nbsp;&nbsp;|&nbsp;&nbsp;
<a href='http://www.property24.com' target='_self' data-track='outbound,topbar,property24.com'>PROPERTY24</a>&nbsp;&nbsp;|&nbsp;&nbsp;
<a href='http://www.careers24.com' target='_self' data-track='outbound,topbar,careers24.com'>CAREERS24</a>&nbsp;&nbsp;|&nbsp;&nbsp;
<a href='http://www.spree.co.za?utm_source=24com+network&utm_medium=Masthead+links&utm_campaign=Channel24' target='_self' data-track='outbound,topbar,spree.com'>SPREE</a>&nbsp;&nbsp;|&nbsp;&nbsp;
</span></div></div><div class='clr10'>&nbsp;</div></div></div>

        

<div id="leaderboard" class="leaderboard">
    <!-- place the advert here-->
    <div class="adCenter">   
        <div id="ad-728x90-1" class="24ad728x90"><script type="text/javascript">if(typeof za24_DisplayAd != "undefined") za24_DisplayAd("728x90","1");</script></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=728x90&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=728x90&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" border="0" alt="" /></a></noscript>      
    </div>
</div>

        <div id="main_wrapper" class="container">
            
	<script>var headerSearchUrl = 'http://search.channel24.co.za/search?s=ENT24&ref=ENT24&q=';
var headerAdvancedSearchUrl = 'http://search.channel24.co.za/advanced?s=ENT24&ref=ENT24&q=';
var txtSearchFieldClientId = 'txtSearchField';
var btnSearchClientId = 'btnSearch';
function submitSiteSearch(useAdvanced){var sUrl = useAdvanced ? headerAdvancedSearchUrl : headerSearchUrl; window.location=sUrl + document.getElementById(txtSearchFieldClientId).value;}
</script>

<header>
    <article class="header_logo_article">
        <a href="/" class="logo">
            <img src="/The-Juice/images/logo.png" width="235" /></a>
    </article>
    <div class="juice_logo">
        <img src="/The-Juice/images/juice.png" width="180" />
    </div>
    <div style="clear: both"></div>
    
    <section class="search_box">
        <input name="ctl00$ctl00$HeadingPlaceHolder$header$txtSearchField" type="text" id="txtSearchField" onkeypress="var key=event.keyCode||event.which;if (key==13){submitSiteSearch(); return false;}" class="field" />
        <input name="ctl00$ctl00$HeadingPlaceHolder$header$btnSearch" type="submit" id="btnSearch" onclick="submitSiteSearch(false); return false;" class="btn" value="Search" />
    </section>
    <ul onmouseout="SetSelections(defaultTabId);" onmouseover="RemoveSelections();" id="nav">
	<li id="tablink0" class="nav_item no_arrow"><a target="_self" href="/News" data-track="outbound,nav,1stlevel-News">News</a></li><li id="tablink1" class="nav_item no_arrow"><a target="_self" href="/Gossip" data-track="outbound,nav,1stlevel-Gossip">Gossip</a></li><li id="tablink2" class="nav_item"><a target="_self" href="/Movies" data-track="outbound,nav,1stlevel-Movies">Movies</a><ul>
		<li><a data-track="nav,2ndlevel-Movies,News" target="_self" href="/Movies/News">News</a></li><li><a data-track="nav,2ndlevel-Movies,Reviews" target="_self" href="/Movies/Reviews">Reviews</a></li><li><a data-track="nav,2ndlevel-Movies,Opening-Soon" target="_self" href="/Movies/OpeningSoon">Opening Soon</a></li>
	</ul></li><li id="tablink3" class="nav_item"><a target="_self" href="/TV" data-track="outbound,nav,1stlevel-TV">TV</a><ul>
		<li><a data-track="nav,2ndlevel-TV,News" target="_self" href="/TV/News">News</a></li><li><a data-track="nav,2ndlevel-TV,TV-Guide" target="_self" href="/TV/TVGuide">TV Guide</a></li><li><a data-track="nav,2ndlevel-TV,Soapie-Updates" target="_self" href="/TV/soapies">Soapie Updates</a></li>
	</ul></li><li id="tablink4" class="nav_item"><a target="_self" href="/Music" data-track="outbound,nav,1stlevel-Music">Music</a><ul>
		<li><a data-track="nav,2ndlevel-Music,News" target="_self" href="/Music/News">News</a></li><li><a data-track="nav,2ndlevel-Music,Local-Music" target="_self" href="/Music/Local-Music">Local Music</a></li><li><a data-track="nav,2ndlevel-Music,Reviews" target="_self" href="/Music/AlbumReviews">Reviews</a></li><li><a data-track="nav,2ndlevel-Music,Rocking-the-Daisies" target="_self" href="/rocking-the-daisies">Rocking the Daisies</a></li>
	</ul></li><li id="tablink5" class="nav_item no_arrow"><a target="_self" href="/Viral" data-track="outbound,nav,1stlevel-Viral">Viral</a></li><li id="tablink6" class="nav_item no_arrow"><a target="_self" href="/Paparazzi" data-track="outbound,nav,1stlevel-Paparazzi">Paparazzi</a></li><li id="tablink7" class="nav_item no_arrow"><a target="_self" href="/Competitions" data-track="outbound,nav,1stlevel-Competitions">Competitions</a></li><li id="tablink8" class="nav_item no_arrow"><a target="_self" href="/Bloke" data-track="outbound,nav,1stlevel-Bloke">Bloke</a></li><li id="tablink9" class="nav_item no_arrow"><a target="_self" href="/The-Juice" data-track="outbound,nav,1stlevel-The-Juice">The Juice</a></li>
</ul><script type='text/javascript'>menuJsonArray = [{"Url":"http://sites.channel24.co.za/News","TabLinkIndex":0,"TabLinkToActivate":"tablink0"},{"Url":"http://sites.channel24.co.za/Gossip","TabLinkIndex":1,"TabLinkToActivate":"tablink1"},{"Url":"http://sites.channel24.co.za/Movies/News","TabLinkIndex":2,"TabLinkToActivate":"tablink2"},{"Url":"http://sites.channel24.co.za/Movies/Reviews","TabLinkIndex":2,"TabLinkToActivate":"tablink2"},{"Url":"http://sites.channel24.co.za/Movies/OpeningSoon","TabLinkIndex":2,"TabLinkToActivate":"tablink2"},{"Url":"http://sites.channel24.co.za/Movies","TabLinkIndex":2,"TabLinkToActivate":"tablink2"},{"Url":"http://sites.channel24.co.za/TV/News","TabLinkIndex":3,"TabLinkToActivate":"tablink3"},{"Url":"http://sites.channel24.co.za/TV/TVGuide","TabLinkIndex":3,"TabLinkToActivate":"tablink3"},{"Url":"http://sites.channel24.co.za/TV/soapies","TabLinkIndex":3,"TabLinkToActivate":"tablink3"},{"Url":"http://sites.channel24.co.za/TV","TabLinkIndex":3,"TabLinkToActivate":"tablink3"},{"Url":"http://sites.channel24.co.za/Music/News","TabLinkIndex":4,"TabLinkToActivate":"tablink4"},{"Url":"http://sites.channel24.co.za/Music/Local-Music","TabLinkIndex":4,"TabLinkToActivate":"tablink4"},{"Url":"http://sites.channel24.co.za/Music/AlbumReviews","TabLinkIndex":4,"TabLinkToActivate":"tablink4"},{"Url":"http://sites.channel24.co.za/rocking-the-daisies","TabLinkIndex":4,"TabLinkToActivate":"tablink4"},{"Url":"http://sites.channel24.co.za/Music","TabLinkIndex":4,"TabLinkToActivate":"tablink4"},{"Url":"http://sites.channel24.co.za/Viral","TabLinkIndex":5,"TabLinkToActivate":"tablink5"},{"Url":"http://sites.channel24.co.za/Paparazzi","TabLinkIndex":6,"TabLinkToActivate":"tablink6"},{"Url":"http://sites.channel24.co.za/Competitions","TabLinkIndex":7,"TabLinkToActivate":"tablink7"},{"Url":"http://sites.channel24.co.za/Bloke","TabLinkIndex":8,"TabLinkToActivate":"tablink8"},{"Url":"http://sites.channel24.co.za/The-Juice","TabLinkIndex":9,"TabLinkToActivate":"tablink9"}];</script>
</header>

<div id="pushDownAd">
    <div id="ad-980x90-1" class="24ad980x90"><script type="text/javascript">if(typeof za24_DisplayAd != "undefined") za24_DisplayAd("980x90","1");</script></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=980x90&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=980x90&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" border="0" alt="" /></a></noscript>
</div>
 

            
	<!-- Main Content  //-->
	<div id="main_content" class="main_content_top">    
		 <!-- Section Content  //-->
		
    <div id="super_rugby_left" class="column_left">
        <div id="divEvents3rdLevelNav">
	<div class="eventnav">
    <a id="h2ParentLevelName" class="ss-nav-title"></a>
		<ul id="ulThirdLevel">
		</ul>			
	</div>
</div>
        

<div id="hottopicsbar" class="hot_topic">
    <div id="catDisplayNameClass" class="headline left">
        <span class="hot_title">HOT TOPICS:</span>
    </div>
    <div id="divHotTopics" class="hot_content">
        <a href='http://www.channel24.co.za/Viral'>Viral</a> | <a href='http://www.channel24.co.za/The-Juice/'>Local Gossip</a> | <a href='http://www.channel24.co.za/Movies'>Movies</a> | <a href='http://www.channel24.co.za/TV'>TV</a>
    </div>
</div>
        <script type="text/javascript" language="javascript" src="/The-Juice/scripts/jquery.cluetip.min.js?v=20170213" ></script>

<article>
    <div class="article_header" id="article-body">
        <h1>SA’s Terry Pheto meets Viola Davis and snaps an awesome pic!</h1>
        <span class="datestamp"><img src="/The-Juice/images/clock.png" width="12" /> 41 minutes ago</span>
        <div class="byline">
            
        </div>
        <div class="article-share">
            

<div class="share_tool_24">
    <span class="share_text">share this</span>
    <div class="share24" ></div><link href='http://scripts.24.co.za//libs/24com/socialshare/1.0/share24.min.css?v=17' rel='stylesheet' />
<script type='text/javascript' src='http://scripts.24.co.za//libs/24com/socialshare/1.0/share24.min.js?v=16'></script> 
<script type='text/javascript'>
$j(document).ready(function(){
$j('.share24').share24('dark', []);
});
</script>

    
</div>
        </div>
    </div>
    <div id="articleImageContainer" class="article-image">
        <img src="http://cdn.24.co.za/files/Cms/General/d/1755/99f7736be77e46a38cdce37efb0b6ec0.jpg" id="imgArticleImage" alt="Terry Pheto" />
        <div class="caption">
            Terry Pheto meets Viola Davis. (Photos: Getty/Instagram)<span class="source"></span>
        </div>
        

<div class="related-links-container">
    <div class="contained">
        <div class="relatedlinks">
            <h5>Related Links</h5>
            <ul>
        
                <li><a id="lnkRelatedTitle" href="http://www.channel24.co.za/The-Juice/News/pics-terry-pheto-shines-at-the-essence-black-women-in-hollywood-awards-20170224">PICS: Terry Pheto shines at the Essence Black Women in Hollywood Awards</a></li>
            
                <li class="alt"><a id="lnkRelatedTitle" href="http://www.channel24.co.za/The-Juice/News/terry-pheto-looks-floral-and-fantastic-on-the-cover-of-bona-20170221">Terry Pheto looks floral and fantastic on the cover of Bona</a></li>
            
                <li><a id="lnkRelatedTitle" href="http://www.channel24.co.za/The-Juice/News/bet-praises-terry-pheto-for-her-portrayal-of-winnie-mandela-20170217">BET praises Terry Pheto for her portrayal of Winnie Mandela</a></li>
            
            </ul>
        </div>
    </div>
</div>

    </div>
    <p></p><p>Cape Town &ndash; South African actress and all-round sweetheart, <a href="http://www.channel24.co.za/The-Juice/News/pics-terry-pheto-shines-at-the-essence-black-women-in-hollywood-awards-20170224"><strong>Terry Pheto</strong></a> rubbed shoulders with Hollywood A-listers at this year's Essence Black Women in Hollywood Awards.</p><p>Terry attended the glamourous event on Thursday night and looked absolutely beautiful in a navy blue, semi-sheer dress.</p><p>According to Essence the awards honour &ldquo;the most dynamic black women in Hollywood.&rdquo;</p><p>The talented local star recently received rave reviews for her role as Naledi Khama in the film <em>A United Kingdom</em>.</p><p>During her attendance at the Essence Black Women in Hollywood Awards, the 35-year-old got to pose for a photo with Oscar nominated actress, Viola Davis.</p><p>Viola is the favourite to walk away with the golden Oscar statuette on Sunday night during the 89th Academy Awards. Her portrayal of Rose Maxson in the gripping drama <em>Fences</em> has garnered her much critical acclaim as well as a Golden Globe award in January.</p><p><strong>SEE TERRY AND VIOLA&rsquo;S SNAP HERE:</strong></p><div class="embed other"></div><div class="embed other"><blockquote class="instagram-media" data-instgrm-version="7" style="background:#FFF;border:0;border-radius:3px;box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15);margin:1px;max-width:658px;padding:0;width:99.375%;width:-webkit-calc(100% - 2px);width:calc(100% - 2px);"><div style="padding:8px;"><div style="background:#F8F8F8;line-height:0;margin-top:40px;padding:62.4537037037037% 0;text-align:center;width:100%;"><div style="background:url(data:image/png;display:block;height:44px;margin:0 auto -44px;position:relative;top:-22px;width:44px;"></div></div><p style="color:#c9c8cd;font-family:Arial,sans-serif;font-size:14px;line-height:17px;margin-bottom:0;margin-top:8px;overflow:hidden;padding:8px 0 7px;text-align:center;text-overflow:ellipsis;white-space:nowrap;"><a href="https://www.instagram.com/p/BQ5o8waFO_A/" style="color:#c9c8cd;font-family:Arial,sans-serif;font-size:14px;font-style:normal;font-weight:normal;line-height:17px;text-decoration:none;" target="_blank">A post shared by Terry Pheto (@terrypheto)</a> on <time datetime="2017-02-24T16:13:05+00:00" style="font-family:Arial,sans-serif;font-size:14px;line-height:17px;">Feb 24, 2017 at 8:13am PST</time></p></div></blockquote><script async="" defer="defer" src="https://platform.instagram.com/en_US/embeds.js"></script></div><p><strong></strong></p><p>Terry also posed for a photo with American film, stage, and television actress, Alfre Woodard.</p><p>According to Terry, Alfre is one of her favourite leading ladies in Hollywood. &ldquo;So much love and respect for Alfre Woodard. Thank you for your wise and kind words. Can't wait to see you again soon,&rdquo; Terry captioned the pic.<br /></p><p><strong>SEE TERRY AND ALFRE&rsquo;S PIC HERE:</strong></p><div class="embed other"><blockquote class="instagram-media" data-instgrm-version="7" style="background:#FFF;border:0;border-radius:3px;box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15);margin:1px;max-width:658px;padding:0;width:99.375%;width:-webkit-calc(100% - 2px);width:calc(100% - 2px);"><div style="padding:8px;"><div style="background:#F8F8F8;line-height:0;margin-top:40px;padding:50.0% 0;text-align:center;width:100%;"><div style="background:url(data:image/png;display:block;height:44px;margin:0 auto -44px;position:relative;top:-22px;width:44px;"></div></div><p style="color:#c9c8cd;font-family:Arial,sans-serif;font-size:14px;line-height:17px;margin-bottom:0;margin-top:8px;overflow:hidden;padding:8px 0 7px;text-align:center;text-overflow:ellipsis;white-space:nowrap;"><a href="https://www.instagram.com/p/BQ5BIeLlLyw/" style="color:#c9c8cd;font-family:Arial,sans-serif;font-size:14px;font-style:normal;font-weight:normal;line-height:17px;text-decoration:none;" target="_blank">A post shared by Terry Pheto (@terrypheto)</a> on <time datetime="2017-02-24T10:25:09+00:00" style="font-family:Arial,sans-serif;font-size:14px;line-height:17px;">Feb 24, 2017 at 2:25am PST</time></p></div></blockquote><script async="" defer="defer" src="https://platform.instagram.com/en_US/embeds.js"></script></div><p><strong></strong><br /></p>
    <a id="lnkTxtCredit" class="credit_block" target="_blank" style="text-decoration:none!important;color:#222222;"><p id="accreditationText">-TheJuice</p></a>
<div class="credit">
    <a id="lnkImgCredit" target="_blank"></a>
</div>
    <div class="share_right">
        

<div class="share_tool_24">
    <span class="share_text">share this</span>
    
    
        <div class="shareBlock" data-twittersharename="Sport24news"></div>

        <script>
            $j(document).ready(function () {
                $j(".shareBlock").share24("dark", null);
            });
        </script>
    
</div>
    </div>
    <div class="bannerads">
        <div id="ad-468x120-1" class="24ad468x120"><script type="text/javascript">if(typeof za24_DisplayAd != "undefined") za24_DisplayAd("468x120","1");</script></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=468x120&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=468x120&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" border="0" alt="" /></a></noscript>
    </div>
    

<div id="divKeywordsListing" class="read_more_slider">
    
            <span>Read more on: </span>
        
            <a href="http://www.news24.com/Tags/People/alfre_woodard" id="lnkTag">alfre woodard</a>                     
        
            <a href="http://www.news24.com/Tags/People/viola_davis" id="lnkTag">viola davis</a>                     
        
            <a href="http://www.news24.com/Tags/People/terry_pheto" id="lnkTag">terry pheto</a>                     
        
            <a href="http://www.news24.com/Tags/Places/south_africa" id="lnkTag">south africa</a>                     
        
            <a href="http://www.news24.com/Tags/Places/hollywood" id="lnkTag">hollywood</a>                     
        
            <a href="http://www.news24.com/Tags/Topics/local_celebrities" id="lnkTag">local celebrities</a>                     
        
            <a href="http://www.news24.com/Tags/Topics/celebrities" id="lnkTag">celebrities</a>                     
        
</div>
</article>

<script type="text/javascript">
    $j(document).ready(function () { var a = $j("a.tips"); a.each(function () { var a = $j(this); a.attr("rel", "/Handlers/WhosWhoTooltip.ashx?url=" + a.attr("rel")) }); a.cluetip({ positionBy: "fixed", topOffset: "-230", leftOffset: "-30", sticky: true, dropShadow: false, showTitle: false, mouseOutClose: true, closeText: "", cluezIndex: 5100 }) })
</script>

        
<div class="more_juice">
    <h1>More Juice</h1>
    
            <ul>
        
            <li>
                <a href="http://www.channel24.co.za/The-Juice/News/watch-kwestas-new-music-video-shows-his-softer-side-20170225" id="lnkarticle">> WATCH: Kwesta's new music video shows his softer side</a>
            </li>
        
            <li>
                <a href="http://www.channel24.co.za/The-Juice/News/pics-terry-pheto-shines-at-the-essence-black-women-in-hollywood-awards-20170224" id="lnkarticle">> PICS: Terry Pheto shines at the Essence Black Women in Hollywood Awards</a>
            </li>
        
            </ul>
        
</div>
        

<script type="text/javascript" src="http://scripts.24.co.za/libs/24com/comments/3.0.1/scripts/comments.min.js"></script>
<script type="text/javascript">
    $j(function() {
        if (typeof commentControl !== "undefined") {
            // settings
            commentControl.sortOrder = "Asc";
            commentControl.pageSize = 20;
            commentControl.tinaBaseUrl = "http://auth.channel24.co.za";
            commentControl.commentStatus = "Disabled";
            commentControl.lang = false ? "af" : "en";
            commentControl.locale = "en-za";
            commentControl.site = "Channel";
            commentControl.breadCrumb = "Channel|The-Juice|News" ;
            commentControl.objectId = "363231a0-35cb-43f4-bab6-04574cdd7709";
            commentControl.isDev = false ;
            commentControl.canShowPostedComment = true ;
            commentControl.logOutUrl = "http://auth.channel24.co.za/DeAuthenticate.aspx?surl=" + encodeURIComponent(document.location);
            commentControl.auth.user.id = "00000000-0000-0000-0000-000000000000";
            commentControl.auth.user.displayName = "";
            commentControl.auth.user.clickThrough = "";
            commentControl.auth.user.avatarUrl = "http://cdn.24.co.za/Files/RAP2/d/DefaultAvatar/Small.png";
            commentControl.auth.user.openIdType = 0 ;
            commentControl.FacebookHandlerUrl = "/The-Juice/FacebookToken.ashx";
            commentControl.cacheFacebookAvatar = true;
            commentControl.policyLink = "http://www.news24.com/MyNews24/YourStory/News24s-Comments-Policy-20101109";
            if (commentControl.auth.util.isFacebookProfile("")) {
                commentControl.auth.user.facebookProfileId = commentControl.auth.util.getFbProfileIdFromAvatarUrl("");
            }
            commentControl.init();
        }
    });
</script>



    </div>

		
		 <!-- Aside Widgets  //-->
        <aside class="column300">              
    		
    <div id="super_rugby_right">
        

<script language="javascript" type="text/javascript">
    var tabsClass =
    {
        tabSetArray: new Array(),
        classOn: "active",
        classOff: "disabled",

        addTabs: function (tabsContainer)
        {
            tabs = document.getElementById(tabsContainer).getElementsByTagName("div");
            for (x in tabs)
            {
                if (typeof (tabs[x].id) != "undefined")
                {
                    this.tabSetArray.push(tabs[x].id);
                } else
                { }
            }
        },

        switchTab: function (element)
        {
            for (x in this.tabSetArray)
            {
                tabItem = this.tabSetArray[x];
                dataElement = document.getElementById(tabItem + "_data");
                if (dataElement)
                {
                    if (dataElement.style.display != "none")
                    {
                        dataElement.style.display = "none";
                    } else
                    { }
                } else
                { }

                tabElement = document.getElementById(tabItem);
                if (tabElement)
                {
                    if (tabElement.className != this.classOff)
                    {
                        tabElement.className = this.classOff;
                    } else
                    { }
                } else
                { }
            }

            document.getElementById(element.id + "_data").style.display = "";
            element.className = this.classOn;
        }
    };
</script>

<div class="most-tab">
    <div id="mostTabContainer" class="tabs-sections">
        <div id="tab_read" class="most_read_tab active" onmouseover="tabsClass.switchTab(this);">Most Read</div>
    </div>
    <div class="tabs-content">
        <div id="tab_read_data" class="most-read active tab-wrapper">
            
                    <ul class="bold">
                
                    <li>
                        <a id="lnkArticle" href="http://www.channel24.co.za/The-Juice/News/7-pics-of-riky-rick-living-his-best-life-in-milan-20170223">7 pics of Riky Rick living his best life in Milan</a></li>
                
                    <li class="alt">
                        <a id="lnkArticle" href="http://www.channel24.co.za/The-Juice/News/pics-trevor-noah-khaya-dlanga-and-anele-mdoda-go-bowling-in-la-20170224">PICS: Trevor Noah, Khaya Dlanga and Anele Mdoda go bowling in LA</a></li>
                
                    <li>
                        <a id="lnkArticle" href="http://www.channel24.co.za/TV/News/heres-what-its-like-to-get-married-at-first-sight-20170224">Here's what its like to get married at first sight</a></li>
                
                    <li class="alt">
                        <a id="lnkArticle" href="http://www.channel24.co.za/Movies/News/movie-guide-5-fresh-flicks-to-see-20170224">MOVIE GUIDE: 5 fresh flicks to see</a></li>
                
                    <li>
                        <a id="lnkArticle" href="http://www.channel24.co.za/Gossip/News/watch-caitlyn-jenner-calls-trumps-transgender-decision-a-disaster-20170224">WATCH: Caitlyn Jenner calls Trump's transgender decision 'a disaster'</a></li>
                
                    </ul>
                
        </div>
        <script type="text/javascript">
            tabsClass.addTabs("mostTabContainer");
        </script>
    </div>
    <div class="tabs-ad">
        <div id="ad-278x76-1" class="24ad278x76"><script type="text/javascript">if(typeof za24_DisplayAd != "undefined") za24_DisplayAd("278x76","1");</script></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=278x76&c=110040209&t=artid%3d5160f89c-481e-402e-ac1a-821fa5385c42%26People%3dkwesta%26Topics%3dlocal+celebrities%2clocal+music%26accreditation%3dthe+juice%26posno%3d1" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=278x76&c=110040209&t=artid%3d5160f89c-481e-402e-ac1a-821fa5385c42%26People%3dkwesta%26Topics%3dlocal+celebrities%2clocal+music%26accreditation%3dthe+juice%26posno%3d1" border="0" alt="" /></a></noscript>
    </div>
</div>

        <div class="adblocktower noad300x600pos1">
            <div id="ad-300x600-1" class="24ad300x600"><script type="text/javascript">if(typeof za24_DisplayAd != "undefined") za24_DisplayAd("300x600","1");</script></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=300x600&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=300x600&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" border="0" alt="" /></a></noscript>
        </div>
         
        
 
<div class="spacer5 clr"><!--horz_space--></div> 
<div class="read_next_box">
    <div class="read_next_header">What to Read Next</div><div>
            <div class="left left_item">
                <a href="http://www.channel24.co.za/The-Juice/News/phat-joe-pulled-off-air-following-down-syndromecomments-20170222" id="aArticle" data-track="what-to-read-next"><img src="http://cdn.24.co.za/files/Cms/General/d/4368/341a0a78c3744ca4b641b1ed8b208298.jpg" id="imgArticle" class="left what-to-read-next" /></a>
                <div class="read_wrapper">
                    <div class="numbered">01</div>
	                <h4 class="bold"><a href="http://www.channel24.co.za/The-Juice/News/phat-joe-pulled-off-air-following-down-syndromecomments-20170222" id="ArticleTitle" data-track="outbound,whattoreadnext">Phat Joe pulled off air following 'Down syndrome' comments</a></h4>
                </div>
            </div>
            
            <div class="left left_item">
                <a href="http://www.channel24.co.za/The-Juice/News/snap-anele-mdoda-hangs-out-with-luke-wilson-20170222" id="aArticle" data-track="what-to-read-next"><img src="http://cdn.24.co.za/files/Cms/General/d/5003/81e5049ea37b42d5a6bff6af8edef748.jpg" id="imgArticle" class="left what-to-read-next" /></a>
                <div class="read_wrapper">
                    <div class="numbered">02</div>
	                <h4 class="bold"><a href="http://www.channel24.co.za/The-Juice/News/snap-anele-mdoda-hangs-out-with-luke-wilson-20170222" id="ArticleTitle" data-track="outbound,whattoreadnext">SNAP: Anele Mdoda hangs out with Luke Wilson</a></h4>
                </div>
            </div>
            
            <div class="left left_item">
                <a href="http://www.channel24.co.za/The-Juice/News/unathi-dazzles-on-the-cover-of-true-love-magazine-20170222" id="aArticle" data-track="what-to-read-next"><img src="http://cdn.24.co.za/files/Cms/General/d/4233/c54a8284a5df42329525d763cc570f4f.jpg" id="imgArticle" class="left what-to-read-next" /></a>
                <div class="read_wrapper">
                    <div class="numbered">03</div>
	                <h4 class="bold"><a href="http://www.channel24.co.za/The-Juice/News/unathi-dazzles-on-the-cover-of-true-love-magazine-20170222" id="ArticleTitle" data-track="outbound,whattoreadnext">Unathi dazzles on the cover of True Love Magazine</a></h4>
                </div>
            </div>
            
            <div class="left left_item">
                <a href="http://www.channel24.co.za/The-Juice/News/pics-trevor-noah-goes-to-a-theme-park-to-celebrate-his-birthday-20170222" id="aArticle" data-track="what-to-read-next"><img src="http://cdn.24.co.za/files/Cms/General/d/1941/969fd05855ab467bbb6378a00cc68c39.jpg" id="imgArticle" class="left what-to-read-next" /></a>
                <div class="read_wrapper">
                    <div class="numbered">04</div>
	                <h4 class="bold"><a href="http://www.channel24.co.za/The-Juice/News/pics-trevor-noah-goes-to-a-theme-park-to-celebrate-his-birthday-20170222" id="ArticleTitle" data-track="outbound,whattoreadnext">Trevor Noah goes to a theme park to celebrate his birthday</a></h4>
                </div>
            </div>
            
            <div class="left left_item">
                <a href="http://www.channel24.co.za/The-Juice/News/pretty-yende-shines-in-new-york-20170222" id="aArticle" data-track="what-to-read-next"><img src="http://cdn.24.co.za/files/Cms/General/d/4929/6544b8e5fdea44a29f860895b4517dd8.jpg" id="imgArticle" class="left what-to-read-next" /></a>
                <div class="read_wrapper">
                    <div class="numbered">05</div>
	                <h4 class="bold"><a href="http://www.channel24.co.za/The-Juice/News/pretty-yende-shines-in-new-york-20170222" id="ArticleTitle" data-track="outbound,whattoreadnext">Pretty Yende shines in New York</a></h4>
                </div>
            </div>
            </div>
</div>
        

<div class="img5fm">
    <a id="lnk5fmImg" href="http://www.5fm.co.za/sabc/home/5fm/shows/details?id=2ddd0478-4ff0-468e-a94a-49eef7925b9c&amp;title=FRESH%20@%205" target="_blank"><img src="/The-Juice/images/5FM.jpg" alt="" /></a>
</div>
        
        <div class="noad300x250pos1">
            <div id="ad-300x250-1" class="24ad300x250"><script type="text/javascript">if(typeof za24_DisplayAd != "undefined") za24_DisplayAd("300x250","1");</script></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=300x250&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=300x250&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" border="0" alt="" /></a></noscript>
        </div>
    </div>

	    </aside>
	
		<div class="clr"></div>        
	</div>
    
    
        

<div class="quick_links col954">
	<div class="spacer clr"><!--horz_space--></div>
    <div id="divCatBucket" class="item left">
    <h4 class="bold"><a id="lnkCategory" href="http://www.channel24.co.za/News">Entertainment News</a></h4>
    <ul>
    
            <li><a id="lnkArticle" href="http://www.channel24.co.za/Gossip/News/this-is-why-justin-bieber-had-a-wet-stain-in-his-dick-area-20170225">This is why Justin Bieber had a wet stain in his 'dick area'</a></li>
        
            <li><a id="lnkArticle" href="http://www.channel24.co.za/The-Juice/News/sas-terry-pheto-meets-viola-davis-and-snaps-an-awesome-pic-20170225">SA’s Terry Pheto meets Viola Davis and snaps an awesome pic!</a></li>
        
            <li><a id="lnkArticle" href="http://www.channel24.co.za/Movies/Reviews/hidden-figures-20170217">This Oscar nominated film is worth all the buzz</a></li>
        
    </ul>
</div>
    <div id="divCatBucket" class="item left">
    <h4 class="bold"><a id="lnkCategory" href="http://www.channel24.co.za/Music/News">Music</a></h4>
    <ul>
    
            <li><a id="lnkArticle" href="http://www.channel24.co.za/Music/News/heres-you-handy-weekend-gig-guide-20170224">Here’s your handy weekend gig guide</a></li>
        
            <li><a id="lnkArticle" href="http://www.channel24.co.za/Music/News/chill-with-jack-parow-and-francois-van-coke-on-the-lawn-this-weekend-20170223">Large on the Lawn with Jack Parow and Francois van Coke postponed</a></li>
        
            <li><a id="lnkArticle" href="http://www.channel24.co.za/Music/News/we-had-a-quickie-with-dutch-dj-martin-garrix-ahead-of-ultra-south-africa-20170224">We had a quickie with Dutch DJ Martin Garrix ahead of Ultra South Africa</a></li>
        
    </ul>
</div>
    <div id="divCatBucket" class="item left">
    <h4 class="bold"><a id="lnkCategory" href="http://www.channel24.co.za/Movies/News">Movies</a></h4>
    <ul>
    
            <li><a id="lnkArticle" href="http://www.channel24.co.za/Movies/Reviews/hidden-figures-20170217">This Oscar nominated film is worth all the buzz</a></li>
        
            <li><a id="lnkArticle" href="http://www.channel24.co.za/Movies/Reviews/t2-trainspotting-20170217">This nostalgic sequel is only for die-hard fans</a></li>
        
            <li><a id="lnkArticle" href="http://www.channel24.co.za/Movies/News/jimmy-kimmel-talks-hosting-oscars-20170224">Jimmy Kimmel talks hosting Oscars</a></li>
        
    </ul>
</div>
    <div id="divCatBucket" class="item left">
    <h4 class="bold"><a id="lnkCategory" href="http://www.channel24.co.za/TV/News">TV</a></h4>
    <ul>
    
            <li><a id="lnkArticle" href="http://www.channel24.co.za/TV/News/heres-what-its-like-to-get-married-at-first-sight-20170224">Here's what its like to get married at first sight</a></li>
        
            <li><a id="lnkArticle" href="http://www.channel24.co.za/ShowMax/6-hot-shows-to-stream-this-weekend-20170224">6 hot shows to stream this weekend</a></li>
        
            <li><a id="lnkArticle" href="http://www.channel24.co.za/TV/News/kyknet-fiestas-awards-to-air-live-on-tv-tonight-20170223">kykNET Fiëstas Awards to air live on TV tonight</a></li>
        
    </ul>
</div>
    <div id="divCatBucket" class="item left last">
    <h4 class="bold"><a id="lnkCategory" href="http://www.channel24.co.za/Gossip/News">Celebrities</a></h4>
    <ul>
    
            <li><a id="lnkArticle" href="http://www.channel24.co.za/Gossip/News/this-is-why-justin-bieber-had-a-wet-stain-in-his-dick-area-20170225">This is why Justin Bieber had a wet stain in his 'dick area'</a></li>
        
            <li><a id="lnkArticle" href="http://www.channel24.co.za/Gossip/News/watch-oprah-is-the-queen-of-margaritas-and-we-want-one-20170224">WATCH: Oprah is the queen of margaritas and we want one!</a></li>
        
            <li><a id="lnkArticle" href="http://www.channel24.co.za/Gossip/News/robin-thickes-ex-wife-accuses-him-of-evidence-tampering-20170224">Robin Thicke's ex-wife accuses him of evidence tampering</a></li>
        
    </ul>
</div> 
</div>
        

<div class="footer">
    <div class="company">        
        <a href="http://www.24.com" class="twofourdotcom"></a>
        <ul>
            <li>&copy;2017 24.com. All rights reserved.</li>
            <li><a href="http://sites.channel24.co.za/SiteElements/Services/Terms-and-Conditions-Updated-April-2012-20141013">Legal notices</a> · 
            <a href="http://www.thespacestation.co.za/channel/channel24/">Advertise on 24.com</a> · 
            <a class="group" href="http://www.careers24.com/now-hiring/3898-24com/home/">About Us</a> · 
            <a class="group" href="http://sites.channel24.co.za/">Contact Us</a> 
            </li>            
        </ul>        
        <a href="http://www.iabsa.net/" title="Interactive Advertising Bureau" target="_blank" class="dmma"></a>    
    </div>
</div>



    

        </div>
        <div class="main_wrapper">
            
	

        </div>
        <div style="display: none;">
            <div id="ad-1000x1000-1" class="24ad1000x1000"><script type="text/javascript">if(typeof za24_DisplayAd != "undefined") za24_DisplayAd("1000x1000","1");</script></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=1000x1000&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=1000x1000&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" border="0" alt="" /></a></noscript>
        </div>
        
        <div id="ad-200x400-1" class="24ad200x400"><script type="text/javascript">if(typeof za24_DisplayAd != "undefined") za24_DisplayAd("200x400","1");</script></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=200x400&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=/8900/24.com/Web/Channel24/TheJuice/News&sz=200x400&c=1317257501&t=artid%3d363231a0-35cb-43f4-bab6-04574cdd7709%26People%3dalfre+woodard%2cviola+davis%2cterry+pheto%26Places%3dsouth+africa%2chollywood%26Topics%3dlocal+celebrities%2ccelebrities%26accreditation%3dthejuice%26posno%3d1" border="0" alt="" /></a></noscript>
    

<div id="CmsStats" style="z-index:-1; visibility:hidden;">
<script type="text/javascript" language="JavaScript" >
var cmsStatsImage = new Image();
cmsStatsImage.src = "http://stats.24.com/content/image.articleview?rnd=636236107462689121&s=4&c=16265&a=363231a0-35cb-43f4-bab6-04574cdd7709&t=SA%e2%80%99s+Terry+Pheto+meets+Viola+Davis+and+snaps+an+awesome+pic!&ct=The-Juice/News&u=http%3a%2f%2fwww.channel24.co.za%2fThe-Juice%2fNews%2fsas-terry-pheto-meets-viola-davis-and-snaps-an-awesome-pic-20170225&uid=&luid=&sn=";
</script>
<noscript>
<img src="http://stats.24.com/content/image.articleview?rnd=636236107462689121&s=4&c=16265&a=363231a0-35cb-43f4-bab6-04574cdd7709&t=SA%e2%80%99s+Terry+Pheto+meets+Viola+Davis+and+snaps+an+awesome+pic!&ct=The-Juice/News&u=http%3a%2f%2fwww.channel24.co.za%2fThe-Juice%2fNews%2fsas-terry-pheto-meets-viola-davis-and-snaps-an-awesome-pic-20170225&uid=&luid=&sn=" alt=""/>
</noscript>
</div>
</form>

    <script type="text/javascript" language="javascript" src="http://scripts.24.co.za/libs/json/json2.js?v=16" ></script>
    <script type="text/javascript" language="javascript" src="http://scripts.24.co.za/libs/24com/tina/1.0/LoginWindow.js?v=16" ></script>
    <script type="text/javascript" language="javascript" src="/The-Juice/scripts/common-bottom.min.js?v=20170213" ></script>

    <script type="text/javascript">
        function OpenTinaLoginWindow(permission)
        {
            json = { refreshPage: true, loginProvider: 'Facebook', tinaBaseUrl: 'http://auth.channel24.co.za' };
            json.scope = this;

            if (permission) {
                json.permission = permission;
            }

            Tina.openLoginWindow(json);
         }

         $j(document).ready(function ()
         {
             if (screen.height > 600)
                 $j("a.group").fancybox({ 'hideOnContentClick': false, 'frameWidth': 498, 'frameHeight': 585 });
             else
                 $j("a.group").fancybox({ 'hideOnContentClick': false, 'frameWidth': 498, 'frameHeight': 300 });
         });
    </script>
    <!-- COPYRIGHT EFFECTIVE MEASURE -->
<script type="text/javascript">
    (function () {
        var em = document.createElement('script'); em.type = 'text/javascript'; em.async = true;
        em.src = ('https:' == document.location.protocol ? 'https://za-ssl' : 'http://za-cdn') + '.effectivemeasure.net/em.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(em, s);
    })();
</script>
<noscript>
    <img src="//za.effectivemeasure.net/em_image" alt="" style="position: absolute; left: -5px;" />
</noscript>
<!--END EFFECTIVE MEASURE CODE -->

</body>
</html>
