

<!DOCTYPE html>
<!--[if lt IE 7]><html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en"><![endif]-->
<!--[if IE 7]><html class="no-js lt-ie9 lt-ie8" lang="en"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9" lang="en"><![endif]-->
<!--[if IE 9]><html class="no-js ie9" lang="en"><![endif]-->
<!--[if (gt IE 9)|!(IE)]><!-->
<html class="no-js" lang="en">
<!--<![endif]-->
<head><meta name="description" content="Local celebs have arrived at the Sun International&#39;s Sun Arena at Time Square in Pretoria to witness the crowning of Miss South Africa 2019. " /><title>
	WATCH LIVE: Celebrities arrive on the Miss South Africa 2019 red carpet | Channel24
</title><meta charset="utf-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" /><meta name="viewport" content="width=device-width" /><meta name="bitly-verification" content="81a26829a6e4" /><link rel="SHORTCUT ICON" href="../../../favicon.ico" /><meta property="article:published_time" content="2019/08/09 14:44:08"/><meta property="article:modified_time" content="2019/08/09 14:44:08"/><meta property="article:expiration_time" content="2019/08/11 15:48:06"/><meta property="twitter:card" content="summary"/><meta name="twitter:widgets:csp" content="on"/><meta property="twitter:url" content="http://www.channel24.co.za/The-Juice/News/watch-live-celebrities-arrive-on-the-miss-south-africa-2019-red-carpet-20190808"/><meta property="twitter:title" content="WATCH LIVE: Celebrities arrive on the Miss South Africa 2019 red carpet"/><meta property="twitter:site" content="Channel24"/><meta property="twitter:description" content="Local celebs have arrived at the Sun International&#39;s Sun Arena at Time Square in Pretoria to witness the crowning of Miss South Africa 2019. "/><meta property="twitter:image" content="http://cdn.24.co.za/files/Cms/General/d/9083/561194946a7948f1abadbcd9e3f1906f.jpg"/><meta property="og:site_name" content="Channel"/><meta property="fb:app_id" content="166885289993532"/><meta property="fb:page_id" content="233091425159"/><meta property="og:title" content="WATCH LIVE: Celebrities arrive on the Miss South Africa 2019 red carpet"/><meta property="og:type" content="article"/><meta property="og:url" content="http://www.channel24.co.za/The-Juice/News/watch-live-celebrities-arrive-on-the-miss-south-africa-2019-red-carpet-20190808"/><meta property="og:image" content="http://cdn.24.co.za/files/Cms/General/d/9083/024607198c314fdaa7e9b9eba9994338.jpg"/><meta property="og:image:height" content="300"/><meta property="og:image:width" content="300"/><meta property="og:description" content="Local celebs have arrived at the Sun International&#39;s Sun Arena at Time Square in Pretoria to witness the crowning of Miss South Africa 2019. "/><link rel="canonical" href="http://www.channel24.co.za/The-Juice/News/watch-live-celebrities-arrive-on-the-miss-south-africa-2019-red-carpet-20190808"/><script type="text/javascript" language="javascript">
var $share24 ={
articleId: "83cf9fee-4743-4849-9611-01091c7b459e",
url: "http://www.channel24.co.za/The-Juice/News/watch-live-celebrities-arrive-on-the-miss-south-africa-2019-red-carpet-20190808",
text: "WATCH LIVE: Celebrities arrive on the Miss South Africa 2019 red carpet",
categoryid: "16265",
twittersharename: "Channel24"
};
</script>
<link type="text/css" rel="stylesheet" href="/The-Juice/styles/site.css?v=20190401live" /><link type="text/css" rel="stylesheet" href="https://scripts.24.co.za/libs/fancybox/jquery.fancybox.css?v=29live" /><script type="text/javascript" language="javascript" src="/The-Juice/Scripts/common-top.js?v=20190401live" ></script><script type="text/javascript" language="javascript" src="/The-Juice/scripts/menu.js?v=20190401live" ></script><script type="text/javascript" language="javascript" src="https://scripts.24.co.za/libs/fancybox/fancybox-1.3.4.min.js?v=34live" ></script><script type="text/javascript" language="javascript" src="/The-Juice/scripts/jquery.jcarousel.load.js?v=20190401live" ></script>
        <script type="text/javascript">
            var $j = jQuery.noConflict();
            var isHomePage = false;
            document.domain = "channel24.co.za";
            var _sf_startpt = (new Date()).getTime();
            var tinaUrl = 'https://auth.channel24.co.za';
            var logoutUrl = 'https://auth.channel24.co.za/DeAuthenticate.aspx?surl=https://www.channel24.co.za//The-Juice/News/watch-live-celebrities-arrive-on-the-miss-south-africa-2019-red-carpet-20190808';
        </script>
    <script sync type="text/javascript" src="https://scripts.24.co.za/libs/24com/portal/1.0/common.min.js?v=34live"></script><script type="text/javascript">var _gaq = _gaq || [];_gaq.push(['_setDomainName', 'www.channel24.co.za']);_gaq.push(['_setAccount', 'UA-45055449-1']);_gaq.push(['_trackPageview']);
                                    (function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
                                    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
                                    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
                                    })();</script>
    
    <meta name="articleid" content="83cf9fee-4743-4849-9611-01091c7b459e" />

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PWXKZK8');</script>
<!-- End Google Tag Manager -->
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PWXKZK8"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<script type="text/javascript">
    (function(n,a,t,i,v,e,ai){n['NativeAIObject']=v;n[v]=n[v]||function(){
    (n[v].q=n[v].q||[]).push(arguments)},n[v].l=1*new Date();e=a.createElement(t),
    ai=a.getElementsByTagName(t)[0];e.async=1;e.src=i+"?"+(n[v].l-n[v].l%604800000);
    ai.parentNode.insertBefore(e,ai)})
    (window,document,'script','https://cdn.native.ai/js/current/nativeai.js','nativeAI');
    nativeAI('create', '6b1c5d72-d691-4f96-8aed-dca7b6eebabe');
</script>
<link type="text/css" rel="stylesheet" href="https://scripts.24.co.za/libs/nuggad/1.0/nuggad.opt.css?v=1" />
<script type="text/javascript" language="javascript" src="https://scripts.24.co.za/libs/nuggad/1.0/nuggad.common.js?v=1"></script>
<!-- // START 1010172972	channel24.co.za --> <script type="text/javascript">var n_pbt = Array();document.write('<scr'+'ipt type=\"text/javascript\" src=\"//southernx.nuggad.net/rc?nuggn=95508456&nuggsid=1010172972"><\/scr'+'ipt>');</script> <!-- // END  -->
<script type="text/javascript" src="https://survey.nuggad.net/c/layer-html/s:southernx:channel24.co.za/script.js"></script>
<meta property="fb:pages" content="233091425159" />
<!-- Hotjar Tracking Code for http://www.channel24.co.za/ -->
<script>
    (function(h,o,t,j,a,r){
        h.hj=h.hj||function(){(h.hj.q=h.hj.q||[]).push(arguments)};
        h._hjSettings={hjid:308127,hjsv:5};
        a=o.getElementsByTagName('head')[0];
        r=o.createElement('script');r.async=1;
        r.src=t+h._hjSettings.hjid+j+h._hjSettings.hjsv;
        a.appendChild(r);
    })(window,document,'//static.hotjar.com/c/hotjar-','.js?sv=');
</script>
<script async src="//cdn.mediavoice.com/nativeads/script/24com/track.js"></script>
<script type="text/javascript">!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://jamexistence.com/v2/0/ygn2v8BsRECPkbfyefEzp1nccKndmr2g161XlmuizGfdEA2Vh1t9Tfi_E5FdRiw_9eYz1Wed6_9",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,n,a){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var a=o();if(a){var r=t[e].pubads();typeof r.setTargeting===n&&r.setTargeting("admiral-engaged","true")}}a=t[e]=t[e]||{},a.cmd=a.cmd||[],typeof a.pubads===n?r():typeof a.cmd.unshift===n?a.cmd.unshift(r):a.cmd.push(r)}(window,"googletag","function");;;;;</script>
<script async src="https://cdn.brandmetrics.com/survey/script/f1cb3bf53ac84779ab69b9fc703b0ae0.js"></script>
<link href="https://scripts.24.co.za/libs/24com/comments/3.0.6/styles/comments.min.css" type="text/css" rel="stylesheet"></link>
<!-- Start of DClick Header -->
<!-- Site: /8900/24.com/Web/Channel24/, Zone: /TheJuice/News, MapsTo: "News" -->

<script src='//www.googletagservices.com/tag/js/gpt.js' type='text/javascript' async defer></script>
<script src="https://scripts.24.co.za/libs/24com/ads/async/1.1/24AdScript.min.js" language="JavaScript" type="text/javascript"></script>
<script language="JavaScript" type="text/javascript">//<![CDATA[
za24_AdSite='/8900/24.com/Web/Channel24/'; 
za24_AdZone='/TheJuice/News';
za24_DescUrl='http://www.channel24.co.za/The-Juice/News/watch-live-celebrities-arrive-on-the-miss-south-africa-2019-red-carpet-20190808'; 
za24_ArticleId='83cf9fee-4743-4849-9611-01091c7b459e'; 
za24_IsAsync=true;
za24_InterstitialEnabled=false;
za24_KeywordType[1]='artid'; za24_Keywords[1]='83cf9fee-4743-4849-9611-01091c7b459e'; 
za24_KeywordType[2]='events'; za24_Keywords[2]='miss south africa 2019'; 
za24_KeywordType[3]='people'; za24_Keywords[3]='enhle mbali'; 
za24_KeywordType[4]='topics'; za24_Keywords[4]='pageants,local celebrities'; 
za24_KeywordType[5]='accreditation'; za24_Keywords[5]='the juice'; 

za24_AdSize[1]='1000x1000'; za24_AdPositionNo[1]='1'; 
za24_AdSize[2]='728x90'; za24_AdPositionNo[2]='1'; 
za24_AdSize[3]='300x600'; za24_AdPositionNo[3]='1'; 
za24_AdSize[4]='300x250'; za24_AdPositionNo[4]='1'; 
za24_AdSize[5]='980x90'; za24_AdPositionNo[5]='1'; 
za24_AdSize[6]='970x250'; za24_AdPositionNo[6]='1'; 
//--></script>
<!-- End of DClick Header -->
</head>
<body id="superrugby">
    <form name="form1" method="post" id="form1">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="7669230mj9I/R44UOpOtNrt5UMxWipJfffXnFOHaZctBt1vHs7h5PhFziOguJGUfXeF2+mVE3y0WR8UnbzLywM8QMCo=" />

<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="C3ED9682" />
<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="01MRQQDF2NCLb7VT0eKveAu6YNcjVEsM40aDbb9rhxudUQRUJ4nqVdDEfcKgpmSk7ZkwvjXkMxOuUum3j2Y+pXvtJY9Oi8Ib1SfEijMwrGM92hydcfpZx9QchhPaHPAOW+FSkA==" />
        <div style="display: none;">
            <script type="text/javascript">
jQuery('head').append("<link href='https://scripts.24.co.za/libs/24com/ads/2.0/Style/TransAd.css?v=29live' type='text/css' rel='stylesheet' ></link>")
</script>
<script type="text/javascript" src="https://scripts.24.co.za/libs/24com/ads/2.0/script/TransAd.min.js?v=34live"></script>
<div id="ad-10x10-1" class="24ad10x10"></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=0&sz=1&c=234" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=0&sz=1&c=234" border="0" alt="" /></a></noscript>
        </div>

        <div class='personalisationContainer' data-goog-bkdp-hdr><div class='personalisationNav'><div class='topNavWrapper'><div class='bold headerLinks left'><span>
<a href='http://www.news24.com' target='_self' data-track='outbound,topbar,news24.com'>NEWS24</a>&nbsp;&nbsp;|&nbsp;&nbsp;
<a href='https://www.olx.co.za' target='_self' data-track='outbound,topbar,olx.co.za'>OLX</a>&nbsp;&nbsp;|&nbsp;&nbsp;
<a href='https://www.property24.com' target='_self' data-track='outbound,topbar,property24.com'>PROPERTY24</a>&nbsp;&nbsp;|&nbsp;&nbsp;
<a href='https://www.careers24.com' target='_self' data-track='outbound,topbar,careers24.com'>CAREERS24</a>&nbsp;&nbsp;|&nbsp;&nbsp;
<a href='https://superbalist.com/' target='_blank' data-track='outbound,topbar,superbalist.com'>SUPERBALIST</a>&nbsp;&nbsp;|&nbsp;&nbsp;
<a href='https://www.autotrader.co.za/' target='_self' data-track='outbound,topbar,autotrader'>AUTOTRADER</a>&nbsp;&nbsp;|&nbsp;&nbsp;
</span></div></div><div class='clr10'>&nbsp;</div></div></div>

        

<div id="leaderboard" class="leaderboard">
    <!-- place the advert here-->
    <div class="adCenter">   
        <div id="ad-728x90-1" class="24ad728x90"></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=0&sz=1&c=234" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=0&sz=1&c=234" border="0" alt="" /></a></noscript>      
    </div>
</div>

        <div id="main_wrapper" class="container">
            
    <script>var headerSearchUrl = 'http://search.channel24.co.za/search?s=ENT24&ref=ENT24&q=';
var headerAdvancedSearchUrl = 'http://search.channel24.co.za/advanced?s=ENT24&ref=ENT24&q=';
var txtSearchFieldClientId = 'txtSearchField';
var btnSearchClientId = 'btnSearch';
function submitSiteSearch(useAdvanced){var sUrl = useAdvanced ? headerAdvancedSearchUrl : headerSearchUrl; window.location=sUrl + document.getElementById(txtSearchFieldClientId).value;}
</script>

<header>
    <article class="header_logo_article">
        <a href="/" class="logo"><img src="/The-Juice/images/logo.png" width="235" /></a>
    </article>
    <div class="juice_logo">
        <img src="/The-Juice/images/juice.png" width="180" />
    </div>
    <div style="clear: both"></div>
    
    <section class="search_box">
        <input name="ctl00$ctl00$HeadingPlaceHolder$header$txtSearchField" type="text" id="txtSearchField" onkeypress="var key=event.keyCode||event.which;if (key==13){submitSiteSearch(); return false;}" class="field" />
        <input name="ctl00$ctl00$HeadingPlaceHolder$header$btnSearch" type="submit" id="btnSearch" onclick="submitSiteSearch(false); return false;" class="btn" value="Search" />
    </section>
    <ul onmouseout="SetSelections(defaultTabId);" onmouseover="RemoveSelections();" id="nav">
	<li id="tablink0" class="nav_item no_arrow"><a target="_self" href="/News" data-track="outbound,nav,1stlevel-News">News</a></li><li id="tablink1" class="nav_item"><a target="_self" href="/Gossip" data-track="outbound,nav,1stlevel-Gossip">Gossip</a><ul>
		<li><a data-track="nav,2ndlevel-Gossip,News" target="_self" href="/Gossip">News</a></li><li><a data-track="nav,2ndlevel-Gossip,Paparazzi" target="_self" href="/Paparazzi">Paparazzi</a></li>
	</ul></li><li id="tablink2" class="nav_item"><a target="_self" href="/Movies" data-track="outbound,nav,1stlevel-Movies">Movies</a><ul>
		<li><a data-track="nav,2ndlevel-Movies,News" target="_self" href="/Movies/News">News</a></li><li><a data-track="nav,2ndlevel-Movies,Reviews" target="_self" href="/Movies/Reviews">Reviews</a></li><li><a data-track="nav,2ndlevel-Movies,Opening-Soon" target="_self" href="/Movies/OpeningSoon">Opening Soon</a></li>
	</ul></li><li id="tablink3" class="nav_item"><a target="_self" href="/TV" data-property-one="red" data-track="outbound,nav,1stlevel-TV">TV</a><ul>
		<li><a data-track="nav,2ndlevel-TV,News" target="_self" href="/TV/News">News</a></li><li><a data-track="nav,2ndlevel-TV,Reviews" target="_self" href="/TV/Reviews">Reviews</a></li><li><a data-track="nav,2ndlevel-TV,Idols" target="_self" href="/tv/idols">Idols</a></li>
	</ul></li><li id="tablink4" class="nav_item"><a target="_self" href="/Music" data-track="outbound,nav,1stlevel-Music">Music</a><ul>
		<li><a data-track="nav,2ndlevel-Music,News" target="_self" href="/Music/News">News</a></li><li><a data-track="nav,2ndlevel-Music,Reviews" target="_self" href="/Music/AlbumReviews">Reviews</a></li><li><a data-track="nav,2ndlevel-Music,Local-Music" target="_self" href="/Music/Local-Music">Local Music</a></li>
	</ul></li><li id="tablink5" class="nav_item no_arrow"><a target="_self" href="/Competitions" data-track="outbound,nav,1stlevel-Competitions">Competitions</a></li><li id="tablink6" class="nav_item no_arrow"><a target="_self" href="/Gossip/royal-news" data-track="outbound,nav,1stlevel-Royal-News">Royal News</a></li><li id="tablink7" class="nav_item no_arrow"><a target="_self" href="https://video.channel24.co.za/" data-track="outbound,nav,1stlevel-Watch">Watch</a></li><li id="tablink8" class="nav_item no_arrow"><a target="_self" href="/The-Juice" data-track="outbound,nav,1stlevel-The-Juice">The Juice</a></li>
</ul><script type='text/javascript'>menuJsonArray = [{"Url":"http://sites.channel24.co.za/News","TabLinkIndex":0,"TabLinkToActivate":"tablink0"},{"Url":"http://sites.channel24.co.za/Gossip","TabLinkIndex":1,"TabLinkToActivate":"tablink1"},{"Url":"http://sites.channel24.co.za/Paparazzi","TabLinkIndex":1,"TabLinkToActivate":"tablink1"},{"Url":"http://sites.channel24.co.za/Gossip","TabLinkIndex":1,"TabLinkToActivate":"tablink1"},{"Url":"http://sites.channel24.co.za/Movies/News","TabLinkIndex":2,"TabLinkToActivate":"tablink2"},{"Url":"http://sites.channel24.co.za/Movies/Reviews","TabLinkIndex":2,"TabLinkToActivate":"tablink2"},{"Url":"http://sites.channel24.co.za/Movies/OpeningSoon","TabLinkIndex":2,"TabLinkToActivate":"tablink2"},{"Url":"http://sites.channel24.co.za/Movies","TabLinkIndex":2,"TabLinkToActivate":"tablink2"},{"Url":"http://sites.channel24.co.za/TV/News","TabLinkIndex":3,"TabLinkToActivate":"tablink3"},{"Url":"http://sites.channel24.co.za/TV/Reviews","TabLinkIndex":3,"TabLinkToActivate":"tablink3"},{"Url":"http://sites.channel24.co.za/tv/idols","TabLinkIndex":3,"TabLinkToActivate":"tablink3"},{"Url":"http://sites.channel24.co.za/TV","TabLinkIndex":3,"TabLinkToActivate":"tablink3"},{"Url":"http://sites.channel24.co.za/Music/News","TabLinkIndex":4,"TabLinkToActivate":"tablink4"},{"Url":"http://sites.channel24.co.za/Music/AlbumReviews","TabLinkIndex":4,"TabLinkToActivate":"tablink4"},{"Url":"http://sites.channel24.co.za/Music/Local-Music","TabLinkIndex":4,"TabLinkToActivate":"tablink4"},{"Url":"http://sites.channel24.co.za/Music","TabLinkIndex":4,"TabLinkToActivate":"tablink4"},{"Url":"http://sites.channel24.co.za/Competitions","TabLinkIndex":5,"TabLinkToActivate":"tablink5"},{"Url":"http://sites.channel24.co.za/Gossip/royal-news","TabLinkIndex":6,"TabLinkToActivate":"tablink6"},{"Url":"https://video.channel24.co.za/","TabLinkIndex":7,"TabLinkToActivate":"tablink7"},{"Url":"http://sites.channel24.co.za/The-Juice","TabLinkIndex":8,"TabLinkToActivate":"tablink8"}];</script>
</header>

<div id="pushDownAd">
    <div id="ad-980x90-1" class="24ad980x90"></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=0&sz=1&c=234" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=0&sz=1&c=234" border="0" alt="" /></a></noscript>
</div>

<script>
    //Placeholder methods since the common lib assumes script on the site exists for tab rollovers, not used on the juice
    var defaultTabId;
    function RemoveSelections() { }
    function SetSelections(defaultTabId) { }
</script>

            
    <!-- Main Content  //-->
    <div id="main_content" class="main_content_top">
        <!-- Section Content  //-->
        
    <div id="super_rugby_left" class="column_left">
        <div id="divEvents3rdLevelNav">
	<div class="eventnav">
    <a id="h2ParentLevelName" class="ss-nav-title"></a>
		<ul id="ulThirdLevel">
		</ul>			
	</div>
</div>
        

<div id="hottopicsbar" class="hot_topic">
    <div id="catDisplayNameClass" class="headline left">
        <span class="hot_title">HOT TOPICS:</span>
    </div>
    <div id="divHotTopics" class="hot_content">
        <a href='https://www.channel24.co.za/Viral'>Viral</a> | <a href='https://www.channel24.co.za/The-Juice/'>Local Gossip</a> | <a href='https://www.channel24.co.za/Movies'>Movies</a> | <a href='https://www.channel24.co.za/TV'>TV</a>
    </div>
</div>
        <script type="text/javascript" language="javascript" src="/The-Juice/scripts/jquery.cluetip.min.js?v=20190401live" ></script>

<article>
    <div class="article_header" id="article-body">
        <h1>WATCH LIVE: Celebrities arrive on the Miss South Africa 2019 red carpet</h1>
        <span class="datestamp"><img src="/The-Juice/images/clock.png" width="12" /> 2019-08-09 14:44</span>
        <div class="byline">
            
        </div>
        <div class="article-share">
            

<div class="share_tool_24">
    <span class="share_text">share this</span>
    <div class="share24" ></div><link href='https://scripts.24.co.za//libs/24com/socialshare/1.0/share24.min.css?v=29live' rel='stylesheet' />
<script type='text/javascript' src='https://scripts.24.co.za//libs/24com/socialshare/1.0/share24.min.js?v=34live'></script> 
<script type='text/javascript'>
$j(document).ready(function(){
$j('.share24').share24('dark', []);
});
</script>

    
</div>
        </div>
    </div>
    <a id="lnkTxtCredit" class="credit_block" target="_blank"></a>

<div class="credit">
    <a id="lnkImgCredit" href="https://www.channel24.co.za/The-Juice/" target="_blank"><img src="https://cdn.24.co.za/files/Cms/General/d/6127/230c07575d2242038e31f682de52d745.png" id="imgAccred" /></a>
</div>
    <div id="head-video"></div>
    <div id="articleImageContainer" class="article-image">
        <img src="https://cdn.24.co.za/files/Cms/General/d/9083/024607198c314fdaa7e9b9eba9994338.jpg" id="imgArticleImage" alt="Catriona Gray, Tamaryn Green, Demi-Leigh Nel-Peter" />
        <div class="caption">
            Catriona Gray, Tamaryn Green, Demi-Leigh Nel-Peters<span class="source"></span>
        </div>
        

<div class="related-links-container">
    <div class="contained">
        <div class="relatedlinks">
            <h5>Related Links</h5>
            <ul>
        
                <li><a id="lnkRelatedTitle" href="https://www.channel24.co.za/Gossip/News/in-pics-miss-universe-catriona-gray-touches-down-in-sa-and-oh-boy-did-she-bring-that-lava-walk-20190808">IN PICS: Miss Universe Catriona Gray touches down in SA – and oh boy did she bring that lava walk!</a></li>
            
                <li class="alt"><a id="lnkRelatedTitle" href="https://www.channel24.co.za/The-Juice/News/see-the-new-miss-sa-2019-crown-which-took-192-hours-to-make-20190805">WATCH: First look at the new Miss South Africa crown - which took 192 hours to make</a></li>
            
                <li><a id="lnkRelatedTitle" href="https://www.channel24.co.za/The-Juice/News/enhle-mbali-to-host-miss-south-africa-red-carpet-20190801">Enhle Mbali to host Miss South Africa red carpet</a></li>
            
            </ul>
        </div>
    </div>
</div>

    </div>
    <p>Cape Town - Local celebs have arrived at the Sun International's Sun Arena at Time Square in Pretoria to witness the crowning of Miss South Africa 2019.</p><p>Miss South Africa 2019 promised the hottest and most glamorous red carpet in the history of the pageant - and did not disappoint!&nbsp;</p><p>TV personality Enhle Mabli tracks the stars as they make their arrival, broadcast live from Facebook and Instagram.&nbsp;</p><p><em>The winner of the Miss South Africa will walk away with the prestigious title as well as R3 million in prizes and sponsorship deals</em></p><div id='fourth-par-video'></div><p><strong></strong></p><p><strong>WATCH LIVE HERE</strong>:&nbsp;</p><div class="embed other"><iframe allowfullscreen="true" allowtransparency="true" frameborder="0" height="315" scrolling="no" src="https://www.facebook.com/plugins/video.php?href=https%3A%2F%2Fwww.facebook.com%2FMsSouthAfrica%2Fvideos%2F693275941099590%2F&show_text=0&width=560" style="border:none;overflow:hidden;" width="620"></iframe></div><p> </p><p> </p><p><strong>ALSO READ: <a href="https://www.channel24.co.za/The-Juice/News/meet-the-miss-south-africa-2019-judges-20190804">These are the five women who will be choosing your Miss SA 2019</a></strong></p><div><br></div><div id="ad-fluid-1" class="24adfluid"></div>
    <div id="foot-video"></div>
    <div class="share_right">
        

<div class="share_tool_24">
    <span class="share_text">share this</span>
    
    
        <div class="shareBlock" data-twittersharename="Channel24"></div>

        <script>
            $j(document).ready(function () {
                $j(".shareBlock").share24("dark", null);
            });
        </script>
    
</div>
    </div>
    <div class="bannerads">
        <div id="ad-468x120-1" class="24ad468x120"></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=0&sz=1&c=234" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=0&sz=1&c=234" border="0" alt="" /></a></noscript>
    </div>
    

<div id="divKeywordsListing" class="read_more_slider">
    
            <span>Read more on: </span>
        
            <a href="https://www.news24.com/Tags/Events/miss_south_africa_2019" id="lnkTag">miss south africa 2019</a>                     
        
            <a href="https://www.news24.com/Tags/People/enhle_mbali" id="lnkTag">enhle mbali</a>                     
        
            <a href="https://www.news24.com/Tags/Topics/pageants" id="lnkTag">pageants</a>                     
        
            <a href="https://www.news24.com/Tags/Topics/local_celebrities" id="lnkTag">local celebrities</a>                     
        
</div>
</article>

<script type="text/javascript" language="javascript" src="https://videos.oovvuu.com/tfdc/v1/ovu_rec.js?v=20190401live" ></script>

<script type="text/javascript">
    $j(document).ready(function () { var a = $j("a.tips"); a.each(function () { var a = $j(this); a.attr("rel", "/Handlers/WhosWhoTooltip.ashx?url=" + a.attr("rel")) }); a.cluetip({ positionBy: "fixed", topOffset: "-230", leftOffset: "-30", sticky: true, dropShadow: false, showTitle: false, mouseOutClose: true, closeText: "", cluezIndex: 5100 }) })
</script>

        
<div class="more_juice">
    <h1>More Juice</h1>
    
            <ul>
        
            <li>
                <a href="https://www.channel24.co.za/The-Juice/News/fikile-mbalula-reprimands-junior-de-rocka-for-using-his-phone-while-driving-with-his-baby-20190808" id="lnkarticle">> Fikile Mbalula reprimands Junior De Rocka for using his phone while driving with his baby</a>
            </li>
        
            <li>
                <a href="https://www.channel24.co.za/The-Juice/News/rolene-strauss-announces-pregnancy-20190808" id="lnkarticle">> Rolene Strauss announces pregnancy</a>
            </li>
        
            </ul>
        
</div>
        

<script type="text/javascript" src="https://scripts.24.co.za/libs/24com/comments/3.0.6/scripts/comments.min.js"></script>
<script type="text/javascript">
    $j(function() {
        if (typeof commentControl !== "undefined") {
            // settings
            commentControl.sortOrder = "Asc";
            commentControl.pageSize = 20;
            commentControl.tinaBaseUrl = "https://auth.channel24.co.za";
            commentControl.commentStatus = "Disabled";
            commentControl.lang = false ? "af" : "en";
            commentControl.locale = "en-za";
            commentControl.site = "Channel";
            commentControl.breadCrumb = "Channel|The-Juice|News" ;
            commentControl.objectId = "83cf9fee-4743-4849-9611-01091c7b459e";
            commentControl.isDev = false ;
            commentControl.canShowPostedComment = true ;
            commentControl.logOutUrl = "https://auth.channel24.co.za/DeAuthenticate.aspx?surl=" + encodeURIComponent(document.location);
            commentControl.auth.user.id = "00000000-0000-0000-0000-000000000000";
            commentControl.auth.user.displayName = "";
            commentControl.auth.user.clickThrough = "";
            commentControl.auth.user.avatarUrl = "https://cdn.24.co.za/Files/RAP2/d/DefaultAvatar/Small.png";
            commentControl.auth.user.openIdType = 0 ;
            commentControl.FacebookHandlerUrl = "/The-Juice/FacebookToken.ashx";
            commentControl.cacheFacebookAvatar = true;
            commentControl.policyLink = "https://www.news24.com/MyNews24/YourStory/News24s-Comments-Policy-20101109";
            if (commentControl.auth.util.isFacebookProfile("")) {
                commentControl.auth.user.facebookProfileId = commentControl.auth.util.getFbProfileIdFromAvatarUrl("");
            }
            commentControl.init();
        }
    });
</script>



    </div>


        <!-- Aside Widgets  //-->
        <aside class="column300">
            
    <div id="super_rugby_right">
        

<script language="javascript" type="text/javascript">
    var tabsClass =
    {
        tabSetArray: new Array(),
        classOn: "active",
        classOff: "disabled",

        addTabs: function (tabsContainer)
        {
            tabs = document.getElementById(tabsContainer).getElementsByTagName("div");
            for (x in tabs)
            {
                if (typeof (tabs[x].id) != "undefined")
                {
                    this.tabSetArray.push(tabs[x].id);
                } else
                { }
            }
        },

        switchTab: function (element)
        {
            for (x in this.tabSetArray)
            {
                tabItem = this.tabSetArray[x];
                dataElement = document.getElementById(tabItem + "_data");
                if (dataElement)
                {
                    if (dataElement.style.display != "none")
                    {
                        dataElement.style.display = "none";
                    } else
                    { }
                } else
                { }

                tabElement = document.getElementById(tabItem);
                if (tabElement)
                {
                    if (tabElement.className != this.classOff)
                    {
                        tabElement.className = this.classOff;
                    } else
                    { }
                } else
                { }
            }

            document.getElementById(element.id + "_data").style.display = "";
            element.className = this.classOn;
        }
    };
</script>

<div class="most-tab">
    <div id="mostTabContainer" class="tabs-sections">
        <div id="tab_read" class="most_read_tab active" onmouseover="tabsClass.switchTab(this);">Most Read</div>
    </div>
    <div class="tabs-content">
        <div id="tab_read_data" class="most-read active tab-wrapper">
            
                    <ul class="bold">
                
                    <li>
                        <a id="lnkArticle" href="https://www.channel24.co.za/Gossip/News/this-hunky-builder-is-the-spitting-image-of-brad-pitt-and-the-internet-is-freaking-out-20190807">This hunky builder is the spitting image of Brad Pitt – and the internet is freaking out!</a></li>
                
                    <li class="alt">
                        <a id="lnkArticle" href="https://www.channel24.co.za/Music/News/this-south-african-high-school-choirs-version-of-bohemian-rhapsody-is-going-viral-and-we-can-totally-see-why-20190807">This South African High School Choir's version of Bohemian Rhapsody is going viral, and we can totally see why</a></li>
                
                    <li>
                        <a id="lnkArticle" href="https://www.channel24.co.za/Gossip/Royal-News/the-inspiration-behind-meghan-markles-new-childrens-book-will-melt-your-heart-20190808">The inspiration behind Meghan Markle’s new children’s book will melt your heart</a></li>
                
                    <li class="alt">
                        <a id="lnkArticle" href="https://www.channel24.co.za/Gossip/News/prince-charles-looks-just-like-prince-harry-in-this-adorable-throwback-photo-20190807">Prince Charles looks just like Prince Harry in this adorable throwback photo</a></li>
                
                    <li>
                        <a id="lnkArticle" href="https://www.channel24.co.za/The-Juice/News/rolene-strauss-announces-pregnancy-20190808">Rolene Strauss announces pregnancy</a></li>
                
                    </ul>
                
        </div>
        <script type="text/javascript">
            tabsClass.addTabs("mostTabContainer");
        </script>
    </div>
    <div class="tabs-ad">
        <div id="ad-278x76-1" class="24ad278x76"></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=0&sz=1&c=234" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=0&sz=1&c=234" border="0" alt="" /></a></noscript>
    </div>
</div>

        <div class="adblocktower noad300x600pos1">
            <div id="ad-300x600-1" class="24ad300x600"></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=0&sz=1&c=234" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=0&sz=1&c=234" border="0" alt="" /></a></noscript>
        </div>
        
        
 
<div class="spacer5 clr"><!--horz_space--></div> 
<div class="read_next_box">
    
            <div class="read_next_header">What to Read Next</div>
            <div>
                
            <div class="left left_item">
                <a href="http://www.channel24.co.za/The-Juice/News/pic-denise-zimba-gives-first-look-at-baby-leah-and-shes-the-cutest-20190806" id="aArticle" data-track="what-to-read-next"><img src="https://cdn.24.co.za/files/Cms/General/d/9198/a20a3cd65daa4129bc7c79052a43019a.jpg" id="imgArticle" class="left what-to-read-next" /></a>
                <div class="read_wrapper">
                    <div class="numbered">01</div>
	                <h4 class="bold"><a href="http://www.channel24.co.za/The-Juice/News/pic-denise-zimba-gives-first-look-at-baby-leah-and-shes-the-cutest-20190806" id="ArticleTitle" data-track="outbound,whattoreadnext">Denise gives first look at baby Leah </a></h4>
                </div>
            </div>
            
            <div class="left left_item">
                <a href="http://www.channel24.co.za/The-Juice/News/radio2000-and-sabc-mum-on-phat-joes-latest-radio-furore-20190807" id="aArticle" data-track="what-to-read-next"><img src="https://cdn.24.co.za/files/Cms/General/d/9206/1bcadc43a94643f192dee2fd6b6c7bfc.jpg" id="imgArticle" class="left what-to-read-next" /></a>
                <div class="read_wrapper">
                    <div class="numbered">02</div>
	                <h4 class="bold"><a href="http://www.channel24.co.za/The-Juice/News/radio2000-and-sabc-mum-on-phat-joes-latest-radio-furore-20190807" id="ArticleTitle" data-track="outbound,whattoreadnext">Anele accepts Phat Joe's apology after radio furore</a></h4>
                </div>
            </div>
            
            <div class="left left_item">
                <a href="http://www.channel24.co.za/The-Juice/News/ticketpro-issues-full-refund-for-rip-off-disneyland-in-polokwane-20190806" id="aArticle" data-track="what-to-read-next"><img src="https://cdn.24.co.za/files/Cms/General/d/9074/4ce2f915111d4d509361491a9816ecbe.jpg" id="imgArticle" class="left what-to-read-next" /></a>
                <div class="read_wrapper">
                    <div class="numbered">03</div>
	                <h4 class="bold"><a href="http://www.channel24.co.za/The-Juice/News/ticketpro-issues-full-refund-for-rip-off-disneyland-in-polokwane-20190806" id="ArticleTitle" data-track="outbound,whattoreadnext">Full refund for Polokwane Disneyland rip-off </a></h4>
                </div>
            </div>
            
            <div class="left left_item">
                <a href="http://www.channel24.co.za/The-Juice/News/pics-lira-gets-honoured-with-a-barbie-which-looks-just-like-her-20190806" id="aArticle" data-track="what-to-read-next"><img src="https://cdn.24.co.za/files/Cms/General/d/9198/ae24da7e6c824e28bd0b79322e407df3.jpg" id="imgArticle" class="left what-to-read-next" /></a>
                <div class="read_wrapper">
                    <div class="numbered">04</div>
	                <h4 class="bold"><a href="http://www.channel24.co.za/The-Juice/News/pics-lira-gets-honoured-with-a-barbie-which-looks-just-like-her-20190806" id="ArticleTitle" data-track="outbound,whattoreadnext">Lira honoured with a Barbie which looks just like her</a></h4>
                </div>
            </div>
            
            </div>
        
</div>
        <div id="showMax" class="drumwidg_next_box">
    <div class="header">
        <div class="read_next_header">      
             <a href="https://www.news24.com/Drum" id="aReadMoreBottom">
            <img src="/The-Juice/Images/drumLogo.png" id="showMaxLogo" />
        </a>
    </div>
    </div>
    
            <div class="drumwidg_next_box">
        
            <div class="left left_item_list">
                <a href="https://www.channel24.co.za/The-Juice/News/cape-flats-street-dancer-to-represent-sa-in-paris-20190806" id="lnkArticle">
                    <img src="https://cdn.24.co.za/files/Cms/General/d/9201/52692cc793a04aa0b2db919f82401e90.jpg" id="imgArticle" class="left left_item" />
                      </a>
                    <div class="read_wrapper">
                        <h4 class="bold">
                            <a href="https://www.channel24.co.za/The-Juice/News/cape-flats-street-dancer-to-represent-sa-in-paris-20190806" id="articleTitle">Cape Flats street dancer to represent SA in Paris</a>
                        </h4>
                    </div>
            </div>
        
            <div class="left left_item_list">
                <a href="https://www.channel24.co.za/The-Juice/News/benni-mccarthy-welcomes-his-5th-child-and-its-a-boy-20190807" id="lnkArticle">
                    <img src="https://cdn.24.co.za/files/Cms/General/d/9204/e0cb22e755b04d6c9f42f8a5097212cd.png" id="imgArticle" class="left left_item" />
                      </a>
                    <div class="read_wrapper">
                        <h4 class="bold">
                            <a href="https://www.channel24.co.za/The-Juice/News/benni-mccarthy-welcomes-his-5th-child-and-its-a-boy-20190807" id="articleTitle">Benni McCarthy welcomes his 5th child – and it's a boy!</a>
                        </h4>
                    </div>
            </div>
        
            <div class="left left_item_list">
                <a href="https://www.channel24.co.za/The-Juice/News/enhle-mbali-opens-up-about-cheating-scandals-during-interview-with-dj-zinhle-20190805" id="lnkArticle">
                    <img src="https://cdn.24.co.za/files/Cms/General/d/9075/e28d1a4b808647fab0a4283f0c86138c.png" id="imgArticle" class="left left_item" />
                      </a>
                    <div class="read_wrapper">
                        <h4 class="bold">
                            <a href="https://www.channel24.co.za/The-Juice/News/enhle-mbali-opens-up-about-cheating-scandals-during-interview-with-dj-zinhle-20190805" id="articleTitle">Enhle Mbali opens up about cheating scandals during interview with DJ Zinhle</a>
                        </h4>
                    </div>
            </div>
        
            <div class="left left_item_list">
                <a href="https://www.channel24.co.za/The-Juice/News/akhumzi-jeziles-mom-on-moving-into-his-apartment-a-year-after-his-death-i-came-here-for-healing-20190802" id="lnkArticle">
                    <img src="https://cdn.24.co.za/files/Cms/General/d/9190/0c159c9db7404b21a9d06316cfa3dbd2.png" id="imgArticle" class="left left_item" />
                      </a>
                    <div class="read_wrapper">
                        <h4 class="bold">
                            <a href="https://www.channel24.co.za/The-Juice/News/akhumzi-jeziles-mom-on-moving-into-his-apartment-a-year-after-his-death-i-came-here-for-healing-20190802" id="articleTitle">Akhumzi's mom on moving into his apartment a year after his death</a>
                        </h4>
                    </div>
            </div>
        
            </div>
        
    <div class="read_next_header">
          <a href="https://www.news24.com/Drum" id="aReadMoreTop" style="text-transform: none;">Read more from Drum</a>
    </div>
</div>
        <!-- Removed FiveFm user control -->
        
        <div class="noad300x250pos1">
            <div id="ad-300x250-1" class="24ad300x250"></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=0&sz=1&c=234" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=0&sz=1&c=234" border="0" alt="" /></a></noscript>
        </div>
    </div>

        </aside>

        <div class="clr"></div>
    </div>
    <div class="multi-size-ad">
        <div class="spacer clr">
            <!--horz_space-->
        </div>
        
    <div id="ad-970x250-1" class="24ad970x250"></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=0&sz=1&c=234" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=0&sz=1&c=234" border="0" alt="" /></a></noscript>

    </div>
    
        

<div class="quick_links col954">
	<div class="spacer clr"><!--horz_space--></div>
    <div id="divCatBucket" class="item left">
    <h4 class="bold"><a id="lnkCategory" href="http://www.channel24.co.za/News">Entertainment News</a></h4>
    <ul>
    
            <li><a id="lnkArticle" href="https://www.channel24.co.za/The-Juice/News/demi-leigh-on-what-it-takes-to-win-miss-sa-be-genuine-and-be-real-20190802">Demi Leigh on what it takes to win Miss SA: 'Be genuine and be real'</a></li>
        
            <li><a id="lnkArticle" href="https://www.channel24.co.za/The-Juice/News/watch-live-celebrities-arrive-on-the-miss-south-africa-2019-red-carpet-20190808">WATCH LIVE: Celebrities arrive on the Miss South Africa 2019 red carpet</a></li>
        
            <li><a id="lnkArticle" href="https://www.channel24.co.za/The-Juice/News/meet-the-miss-south-africa-2019-judges-20190804">These are the five women who will be choosing your Miss SA 2019</a></li>
        
    </ul>
</div>
    <div id="divCatBucket" class="item left">
    <h4 class="bold"><a id="lnkCategory" href="http://www.channel24.co.za/Music/News">Music</a></h4>
    <ul>
    
            <li><a id="lnkArticle" href="https://www.channel24.co.za/Music/News/the-kiffness-done-with-sabc-after-non-payment-20190808">The Kiffness 'done with SABC' after 'non-payment'</a></li>
        
            <li><a id="lnkArticle" href="https://www.channel24.co.za/Music/News/watch-ariana-grande-shares-stage-with-idol-barbra-streisand-20190808">WATCH: Ariana Grande shares stage with idol Barbra Streisand</a></li>
        
            <li><a id="lnkArticle" href="https://www.channel24.co.za/Music/News/the-head-chorister-of-the-mzansi-youth-choir-on-performing-with-beyonce-we-couldnt-believe-that-queen-bey-came-to-us-20190805">The head chorister of the Mzansi Youth Choir on performing with Beyoncé: 'We couldn't believe that Queen Bey came to us!'</a></li>
        
    </ul>
</div>
    <div id="divCatBucket" class="item left">
    <h4 class="bold"><a id="lnkCategory" href="http://www.channel24.co.za/Movies/News">Movies</a></h4>
    <ul>
    
            <li><a id="lnkArticle" href="https://www.channel24.co.za/Movies/Reviews/scary-stories-to-tell-in-the-dark-20190801">Get your share of scares with this terrifyingly good horror</a></li>
        
            <li><a id="lnkArticle" href="https://www.channel24.co.za/Movies/News/2-new-movies-to-see-this-long-weekend-20190809">2 new movies to see this long weekend</a></li>
        
            <li><a id="lnkArticle" href="https://www.channel24.co.za/Movies/News/milo-ventimiglia-on-his-new-racing-flick-theres-heart-theres-laughter-and-there-are-tears-20190808">Milo Ventimiglia on his new racing flick: 'There’s heart, there’s laughter and there are tears'</a></li>
        
    </ul>
</div>
    <div id="divCatBucket" class="item left">
    <h4 class="bold"><a id="lnkCategory" href="http://www.channel24.co.za/TV/News">TV</a></h4>
    <ul>
    
            <li><a id="lnkArticle" href="https://www.channel24.co.za/TV/News/this-emotional-wildlife-documentary-series-will-connect-you-with-nature-20190809">This emotional wildlife documentary series will connect you with nature</a></li>
        
            <li><a id="lnkArticle" href="https://www.channel24.co.za/TV/News/7-shows-you-wont-believe-are-based-on-real-life-20190808">7 shows you won’t believe are based on real life</a></li>
        
            <li><a id="lnkArticle" href="https://www.channel24.co.za/TV/News/this-was-the-hardest-scene-for-elisabeth-moss-to-film-in-the-handmaids-tale-and-it-might-not-be-what-you-expect-20190808-2">This was the hardest scene for Elisabeth Moss to film in 'The Handmaid's Tale' – and it might not be what you expect</a></li>
        
    </ul>
</div>
    <div id="divCatBucket" class="item left last">
    <h4 class="bold"><a id="lnkCategory" href="http://www.channel24.co.za/Gossip/News">Celebrities</a></h4>
    <ul>
    
            <li><a id="lnkArticle" href="https://www.channel24.co.za/Gossip/News/are-cole-sprouse-and-lili-reinhart-really-broken-up-because-cole-just-admitted-hes-been-trolling-us-all-along-20190808-2">Are Cole Sprouse and Lili Reinhart really broken up? Because Cole just admitted he's been trolling us all along</a></li>
        
            <li><a id="lnkArticle" href="https://www.channel24.co.za/Gossip/News/watch-gabrielle-unions-daughter-swimming-is-the-cutest-thing-youll-see-today-20190808">WATCH: Gabrielle Union’s daughter swimming is the cutest thing you’ll see today</a></li>
        
            <li><a id="lnkArticle" href="https://www.channel24.co.za/Gossip/News/milla-jovovich-is-pregnant-with-baby-no-3-20190808">Milla Jovovich is pregnant with baby no. 3!</a></li>
        
    </ul>
</div> 
</div>
        

<div class="footer">
    <div class="company">        
        <a href="http://www.24.com" class="twofourdotcom"></a>
        <ul>
            <li>&copy;2019 24.com. All rights reserved.</li>
            <li><a href="/SiteElements/Services/Terms-and-Conditions-Updated-April-2012-20141013">Legal notices</a> · 
            <a href="https://www.thespacestation.co.za/channel/channel24/">Advertise on 24.com</a> · 
            <a class="about" href="https://www.careers24.com/now-hiring/3898-24com/home/">About Us</a> · 
            <a class="contact" href="/FeedBack.aspx?iframe">Contact Us</a> 
            </li>            
        </ul>        
        <a href="https://www.iabsa.net/" title="Interactive Advertising Bureau" target="_blank" class="dmma"></a>    
    </div>
</div>



    

        </div>
        <div class="main_wrapper">
            
    

        </div>
        <div style="display: none;">
            <div id="ad-1000x1000-1" class="24ad1000x1000"></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=0&sz=1&c=234" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=0&sz=1&c=234" border="0" alt="" /></a></noscript>
        </div>
        
        <div id="ad-200x400-1" class="24ad200x400"></div><noscript><a href="http://pubads.g.doubleclick.net/gampad/jump?iu=0&sz=1&c=234" target="_blank"><img src="http://pubads.g.doubleclick.net/gampad/ad?iu=0&sz=1&c=234" border="0" alt="" /></a></noscript>
    

<div id="CmsStats" style="z-index:-1; visibility:hidden;">
<script type="text/javascript" language="JavaScript" >
var cmsStatsImage = new Image();
cmsStatsImage.src = "https://stats.24.com/content/image.articleview?rnd=637009624859930162&s=4&c=16265&a=83cf9fee-4743-4849-9611-01091c7b459e&t=WATCH+LIVE%3a+Celebrities+arrive+on+the+Miss+South+Africa+2019+red+carpet&ct=The-Juice/News&u=http%3a%2f%2fwww.channel24.co.za%2fThe-Juice%2fNews%2fwatch-live-celebrities-arrive-on-the-miss-south-africa-2019-red-carpet-20190808&uid=&luid=&sn=";
</script>
<noscript>
<img src="https://stats.24.com/content/image.articleview?rnd=637009624859930162&s=4&c=16265&a=83cf9fee-4743-4849-9611-01091c7b459e&t=WATCH+LIVE%3a+Celebrities+arrive+on+the+Miss+South+Africa+2019+red+carpet&ct=The-Juice/News&u=http%3a%2f%2fwww.channel24.co.za%2fThe-Juice%2fNews%2fwatch-live-celebrities-arrive-on-the-miss-south-africa-2019-red-carpet-20190808&uid=&luid=&sn=" alt=""/>
</noscript>
</div>
</form>

    <script type="text/javascript" language="javascript" src="https://scripts.24.co.za/libs/json/json2.js?v=34live" ></script>
    <script type="text/javascript" language="javascript" src="https://scripts.24.co.za/libs/24com/tina/1.0/LoginWindow.js?v=34live" ></script>
    <script type="text/javascript" language="javascript" src="/The-Juice/scripts/common-bottom.min.js?v=20190401live" ></script>

    <script type="text/javascript">
        function OpenTinaLoginWindow(permission)
        {
            json = { refreshPage: true, loginProvider: 'Facebook', tinaBaseUrl: 'https://auth.channel24.co.za' };
            json.scope = this;

            if (permission) {
                json.permission = permission;
            }

            Tina.openLoginWindow(json);
         }
    </script>
    <!-- COPYRIGHT EFFECTIVE MEASURE -->
<script type="text/javascript">
    (function () {
        var em = document.createElement('script'); em.type = 'text/javascript'; em.async = true;
        em.src = ('https:' == document.location.protocol ? 'https://za-ssl' : 'http://za-cdn') + '.effectivemeasure.net/em.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(em, s);
    })();
</script>
<noscript>
    <img src="//za.effectivemeasure.net/em_image" alt="" style="position: absolute; left: -5px;" />
</noscript>
<!--END EFFECTIVE MEASURE CODE -->

</body>
</html>